No se pueden usar los atajos de teclado IntelliJ IDEA en Ubuntu

117

Soy muy nuevo en Ubuntu y tengo un problema que no sé cómo solucionarlo. Incluso intenté buscar respuestas en la web, pero tal vez no conozco los términos correctos para buscarla.

Trabajo con IntelliJ IDEA , una aplicación para desarrollo. Y estoy muy acostumbrado a los atajos de teclado, pero cuando hice el cambio de Windows XP a Ubuntu 13.10, algunos atajos ya no funcionan. Por ejemplo, como;

  • Ctrl + Alt + & lt; (flecha izquierda)
  • Alt + F8

¿Hay alguna razón de por qué? y hay alguna solución para esto? O tal vez algo para guiarme en mi búsqueda

Muchas gracias a todos por adelantado.

    
pregunta Rodrigo Sasaki 28.01.2014 - 13:01

10 respuestas

187

Un poco de lectura me enseñó que Intellij IDEA es un IDE centrado en el teclado. Lo que significa es que un uso puede funcionar sin tener que tocar el mouse. También administro la configuración de encontrar mapa de teclas.

para Ubuntu

Consulte cómo cambiar los métodos abreviados de teclado?

Aquí hay una lista de ajustes que debe realizar con las asociaciones de teclas predeterminadas del sistema para que no interfieran con las acciones de IntelliJ IDEA (enumeradas entre paréntesis).

  
  • Desactiva la acción de la ventana Sombra, asignada a Ctrl + Alt + S (Diálogo de configuración)
  •   
  • Cambie o deshabilite la acción Bloquear pantalla, asignada a Ctrl + Alt + L (Reformatear código)
  •   
  • Cambie o deshabilite la acción de inicio del terminal, asignada a Ctrl + Alt + T (Surround con)
  •   
  • Cambie o deshabilite la acción Cambiar al área de trabajo, asignada a Ctrl + Alt + Teclas de dirección (Navegación)
  •   
  • Desactiva la acción de la ventana Mover, asignada a Alt + F7 (Buscar usos)
  •   
  • Cambie o deshabilite la acción Cambiar tamaño de la ventana, asignada a Alt + F8 (Evaluar expresión)
  •   

¡Espero que esto ayude!

Nota: siempre puede revertir los accesos directos de Ubuntu a su estado predeterminado. Simplemente consulte ¿Cómo puedo restaurar los atajos de teclado predeterminados? , en caso de que se pierda .

Fuente: - Intellij IDEA Keymap

    
respondido por el AzkerM 28.01.2014 - 13:39
28

También encontré este problema; mi solución, sin embargo, fue diferente.

No es necesario hackear o cambiar el mapa de teclas de todo el sistema

IntelliJ tiene diferentes mapas de teclas, que puede cambiar de acuerdo con su sistema operativo.

Puede cambiar su IntelliJ Keymap desde la configuración.

Simplemente vaya a Settings -> Keymap y seleccione su mapa de teclas deseado en el menú desplegable. En mi caso, elegí "Predeterminado para GNOME" ya que estoy usando Ubuntu Gnome 16.04.

    
respondido por el Francisco C. 25.06.2016 - 07:18
12

Para ubuntu 18.04 LTS ctrl + alt + left (conflicto de atajos de la idea Intellij)

  • instala Dconf Editor en el software de ubuntu
  • ejecuta el editor Dconf, ve a / org / gnome / desktop / wm / keybindings / switch-to-workspace-left

  • haga doble clic como a continuación

  • usa el valor predeterminado (haz clic en Desactivado) - & gt; Valor personalizado (como yo o más)

  • podrías usarlo en una idea inteligente ahora

    
respondido por el think 06.05.2018 - 11:42
5

Creé este script que desactiva todos los accesos directos entre Ubuntu (probado con 15.10) e IntelliJ (y probablemente más productos Jetbrains). Los desactiva en Ubuntu.

También crea un archivo de copia de seguridad para que pueda restaurar su configuración anterior.

Para no tener deshabilitados algunos accesos directos, coméntelos en la matriz KEYS .

#!/bin/bash
set -euo pipefail

# Disables Ubuntu shortcuts that clash with IntelliJ Idea (and probably other
# Jetbrain products).
#
# Creates a backup file to restore the previous settings. To not have some
# shortcuts disabled, comment them out in the 'KEYS' array.
#
# Tested on : Ubuntu 15.10
# Author    : Jonas Gröger

readonly BACKUP_FILE="undo-fix-shortcuts-$(date +%s%N).sh"
readonly KEYS=(
    "/org/gnome/desktop/wm/keybindings/toggle-shaded"
    "/org/gnome/settings-daemon/plugins/media-keys/screensaver"
    "/org/gnome/settings-daemon/plugins/media-keys/terminal"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-down"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-up"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-left"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-right"
    "/org/gnome/desktop/wm/keybindings/begin-move"
    "/org/gnome/desktop/wm/keybindings/begin-resize"
    # To disable resetting a value, just comment out the line
)
readonly DISABLED_VALUE="['disabled']"

main() {
    # Make backup
    printf "#!/bin/bash\n" >>  "$BACKUP_FILE"
    for key in "${KEYS[@]}"; do
        local value
        value=$(dconf read "$key")
        printf "dconf write \"%s\" \"%s\"\n" "$key" "$value" >> "$BACKUP_FILE"
    done

    # Disable all Ubuntu shortcuts
    for key in "${KEYS[@]}"; do
        dconf write "$key" "$DISABLED_VALUE"
    done
}
main

Puedes obtenerlo desde aquí:

wget -O fix-shortcuts.sh https://gist.githubusercontent.com/JonasGroeger/94cfa1071fa12572f465/raw/fix-shortcuts.sh
    
respondido por el Jonas Gröger 16.12.2015 - 22:40
3

Consulte aquí para obtener una forma de deshabilitar los accesos directos de Ubuntu mediante programación y solo si las ventanas de ciertas aplicaciones están activas.

Específicamente, use estos valores (suponiendo que utilice JetBrains Toolbox con su ruta de instalación estándar; adapte lo contrario):

apppattern = "JetBrains"
backupfile = "~/.local/share/JetBrains/keymap_backup"

Mientras se ejecuta la secuencia de comandos, los accesos directos de Ubuntu siempre funcionarán, excepto cuando IDEA et al. tener enfoque.

Tengo una colección de atajos específicos de JetBrains aquí ; la entrada es apreciada.

    
respondido por el Raphael 22.12.2016 - 14:32
2

Solo para ampliar un poco la excelente respuesta de AzkerM:

  
  • Desactiva la acción de la ventana Mover, asignada a Alt + F7 (Buscar usos)      
        
    • desde Configuración - & gt; Teclado - & gt; Atajos - & gt; Windows - & gt; Mover ventana
    •     
  •   
  • Cambie o deshabilite la acción Cambiar tamaño de la ventana, asignada a Alt + F8 (Evaluar expresión)      
        
    • desde Configuración - & gt; Teclado - & gt; Atajos - & gt; Windows - & gt; Cambiar el tamaño de la ventana
    •     
  •   
    
respondido por el WillC 24.02.2016 - 12:15
1

Estoy ejecutando Ubuntu 16.04 y lo que sucedía es que cuando usaba estas teclas (ctrl-alt-left / right), la ventana cambiaba de tamaño y se colocaba a la derecha o izquierda de mi pantalla. Intenté desactivar estas asociaciones de teclas en: Configuración / Teclado / Navegación, aunque no tengo espacios de trabajo habilitados. Aún así no evitó el comportamiento que estaba viendo.

Afortunadamente, abrí Compiz y tropecé con el plugin de Gestión de ventanas / Cuadrícula que estaba mapeando estas teclas para colocar ventanas en una posición de cuadrícula. Inhabilité este complemento y ahora mis atajos de teclado IntelliJ funcionan bien con ctrl-alt-left / right.

    
respondido por el Jason White 14.06.2016 - 00:08
1

Solo una solución rápida:
Si tiene una tecla " Windows " en su teclado, puede agregarla a toda la combinación de atajos; debería funcionar. Por ejemplo:

  • Ctrl + Ganar + Alt + T (Surround con)
  • Ganar + Alt + F8 (Evaluar expresión )
respondido por el guzoff 28.11.2017 - 21:53
0

Para Ubuntu 16.04, vaya a configuración & gt; Teclado y encuentra la combinación particular en conflicto con tu clíc deseado y actualiza la combinación a una nueva.

    
respondido por el Cengkuru Michael 29.10.2017 - 10:22
0

Uso Xneur para cambiar el texto mal escrito a otro idioma. El idioma de mi sistema está clasificado por Ctrl + Shift lo que bloquea las teclas de acceso rápido de Intellij como Ctrl + Shift + F (búsqueda global) y Ctrl + Shift + C (comentario). Entonces el cambio a la izquierda se ignora.

  • Una solución es cambiar el idioma usando Ctrl_L + Shift_L y uso Ctrl_R + Shift_R para Intellij . Pero es una especie de incomodidad.

  • La otra solución es usar Xneur ( sudo ap-get install xneur ) para vuelva a escribir el texto mal escrito en otro idioma. Puede desactivar cualquier cambio de idioma del sistema y asignarlo a xneur teclas de acceso rápido (el mismo Ctrl+Shift ). Xneur se puede agregar a las aplicaciones de inicio automático.

respondido por el Zon 04.09.2018 - 07:28

Lea otras preguntas en las etiquetas