¿Cómo puedo desactivar Bluetooth en el inicio del sistema?

275

¿Cómo puedo desactivar Bluetooth en el inicio del sistema?

    
pregunta Floqqi 16.10.2011 - 23:02

28 respuestas

189

Más de 18.04 usuarios que no tienen un /etc/rc.local, necesitarás crear uno y hacerlo ejecutable. Para facilitar las cosas, puede pegar el siguiente comando en una terminal:

sudo install -b -m 755 /dev/stdin /etc/rc.local << EOF
#!/bin/sh
rfkill block bluetooth
exit 0
EOF

Ejecute sudoedit /etc/rc.local y agregue esto antes de la línea con exit 0 :

rfkill block bluetooth

Debería poder habilitar Bluetooth a través del applet de la barra superior.

Esto debería funcionar para la mayoría de los sistemas, pero parece que hay algunos errores al acecho en el ACPI del kernel para Thinkpads. Si está en un Thinkpad, agregue lo siguiente a /etc/rc.local :

echo disable > /proc/acpi/ibm/bluetooth

O echa un vistazo a ibm-acpi - Controlador de extras de IBM ThinkPad ACPI - algunos informes sugieren que ibm-acpi incluye control por bluetooth (entre otras cosas bonitas). Pero no tengo el hardware, así que no puedo verificar estos reclamos. Buena suerte.

    
respondido por el Oli 18.08.2010 - 11:00
69

Encontré un "cómo hacerlo" con una "solución alternativa" limpia aquí ( enlace de archivo para la posteridad)

En realidad, cambiar el /etc/bluetooth/main.conf fue suficiente para mí.

Del artículo:

Buscar la entrada:

InitiallyPowered = true

y cambie el valor a:

InitiallyPowered = false

Fue suficiente para mí, aunque el artículo describe algunos otros pasos que pueden o no ser necesarios.

En Ubuntu 17.10 y Ubuntu 18.04 la opción InitiallyPowered ha sido reemplazada por AutoEnable

    
respondido por el Stepbaer 25.06.2012 - 20:00
23

Para deshabilitar el controlador bluetooth para que no se cargue al inicio:

sudo $EDITOR /etc/modprobe.d/blacklist.conf

agregar:

blacklist btusb

Habilitarlo más tarde debería ser:

sudo modprobe btusb
    
respondido por el maco 18.08.2010 - 18:59
16

Paso 1: vaya a la terminal y escriba el siguiente comando para editar el archivo /etc/rc.local del sistema:

gksudo gedit /etc/rc.local

Paso 2: agregue la siguiente línea antes de la línea exit 0 :

rfkill block bluetooth
    
respondido por el Varun 04.05.2012 - 22:44
12

Desde ubuntu 16.04 en adelante, systemd administra servicios de inicio como bluetooth ... para ver el problema de estado actual siguiente en un terminal

sudo systemctl status bluetooth.service 

para desactivar bluetooth en el inicio de este problema

sudo systemctl disable bluetooth.service

luego, el próximo reinicio, bluetooth no estará activo ... para habilitar el problema con bluetooth

sudo systemctl enable bluetooth.service
    
respondido por el Scott Stensland 01.08.2017 - 17:08
7

Escriba lo siguiente en un terminal:

sudo gedit /etc/modprobe.d/blacklist.conf

En la parte inferior del archivo, agregue la línea:

blacklist bluetooth

Guarde el archivo y reinícielo: Bluetooth ahora debe estar deshabilitado.

    
respondido por el Nathan Osman 16.10.2011 - 23:25
7

Puede cambiar los servicios iniciados en el arranque con la ayuda de BUM .

Instálelo: sudo apt-get install bum

Ejecutar: sudo bum

Desmarque la casilla y haga clic en Aplicar .

    
respondido por el desgua 05.05.2012 - 02:09
5

Creo que la mejor manera es deshabilitar el inicio del servicio en primer lugar. Hay un método general para deshabilitar servicios que funciona a la perfección:

sudo sh -c "echo 'manual' > /etc/init/bluetooth.override"

Eso funciona para Ubuntu 13.10 y probablemente también para versiones anteriores.

    
respondido por el Felipe 18.01.2014 - 10:49
5

Agrego

"/etc/init.d/bluetooth stop"

en

"/etc/rc.local" 

antes del comando "exit 0" para arrancar con bluetooth apagado.

    
respondido por el Saeed Zarinfam 23.08.2012 - 15:00
5

1. bloquear bluetooth en rc.local

Agregue esta línea al final del archivo /etc/rc.local justo antes de la línea exit 0 :

rfkill block bluetooth

Esto hará el truco, pero solo en versiones anteriores de Ubuntu usando upstart .

2. vuelva a habilitar rc.local en systemd

En Ubuntu 15.10 con systemd como administrador de inicio, el archivo /etc/rc.local ya no se usa de manera predeterminada, así que llámalo a un terminal:

sudo systemctl edit --full rc-local

que abre un editor. Al final del archivo agregué:

[Install]
WantedBy=multi-user.target

Esos cambios están activados por

sudo systemctl reenable rc-local

Ahora el archivo /etc/rc.local se usa como lo conoce.

3. deshabilitar blueman-applet en el inicio

sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/blueman.desktop
gnome-session-properties

Ahora blueman-applet está visible y puede deshabilitarlo desde los programas de inicio

4. Reiniciar para ver el efecto

    
respondido por el rubo77 10.11.2015 - 13:29
4

Puede editar sus configuraciones de update-rc.d . Usé algo similar a:

sudo update-rc.d bluetooth remove

En Debian Wheezy. Consulte man update-rc.d para obtener más información sobre cómo usarlo.

    
respondido por el Keith Smiley 13.02.2013 - 16:50
2

Tal vez puedas desactivarlo en las aplicaciones de inicio. Pero estas aplicaciones están ocultas por defecto. Muestra las aplicaciones de inicio ocultas en 12.04: abre el terminal y ejecuta estos dos comandos:

cd /etc/xdg/autostart/

sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' *.desktop

Ahora puedes desmarcar bluetooth. (¡No eliminar!)

    
respondido por el schiemanski 05.05.2012 - 10:50
2

No. No siempre está en la lista de aplicaciones de inicio. Creo que la mejor solución es agregar el comando rfkill en el script rc.local o establecer el parámetro InitiallyPowered en /etc/bluetooth/main.conf .

    
respondido por el Robert 05.05.2012 - 02:06
2

1) Instale el paquete smbios-utils y agréguelo a Aplicaciones de inicio con:

sudo smbios-wireless-ctl --bt 0

2) En tipo de terminal:

sudo visudo

y agregue al final del archivo abierto /etc/sudoers la línea:

<your username> ALL = NOPASSWD: /usr/sbin/smbios-wireless-ctl

3) Para activar Bluetooth durante la sesión, ejecute en la terminal:

sudo smbios-wireless-ctl --bt 1

Esto funciona para mí en mi Dell D630 con Ubuntu 13.10

    
respondido por el victor 15.03.2014 - 16:58
2

En Ubuntu 16.04, simplemente deshabilité el servicio para que no se inicie usando systemctl.

Para hacerlo, abra una ventana de terminal y escriba lo siguiente:

sudo systemctl disable bluetooth

Puede reiniciar ya que el bluetooth se desactivará desde el inicio, o si no desea reiniciar y desea detener el bluetooth de inmediato, puede escribir:

sudo service bluetooth stop

    
respondido por el Ken 22.08.2017 - 05:57
2

Podemos deshabilitar el inicio automático de bluetooth de esta manera:

sudo gedit /etc/bluetooth/main.conf

( gedit es mi editor favorito, puede reemplazar esto con xed o lo que sea que esté instalado en su sistema).

En la parte inferior de este archivo, hay esta línea:

#AutoEnable=false

Dejar de comentarlo, así:

AutoEnable=false
    
respondido por el Shayan 20.02.2018 - 15:47
1

Uso Sputnik Kernel , que solucionó esto en mi Dell Inspiron 14R N4110.

    
respondido por el Alex Wiedermann 25.09.2012 - 01:53
1

Creo que deberías editar

/etc/default/bluetooth

y establecer

BLUETOOTH_ENABLED=0

para deshabilitar el servicio bluetooth al arrancar

    
respondido por el Fabio 06.03.2014 - 21:17
1

Para aquellos de ustedes donde insertar la línea rfkill block bluetooth (o cualquier otro) en /etc/rc.local no funciona, intenten incluir la misma línea al final de ~/.bashrc

En mi configuración (Ubuntu 14.04, Thinkpad W540), no funcionó la opción insertándolo en /etc/rc.local pero el primero funcionaba en bashrc. Tenga en cuenta que esto funcionará solo para el usuario actual, no globalmente para todos los usuarios.

    
respondido por el Sam 19.10.2014 - 14:10
1

En Ubuntu Studio 16.04 puede deshabilitar Bluetooth Applet en Inicio en:

  

Sesión y inicio & gt; Inicio automático de la aplicación & gt; Applet de Bluetooth

Aquí puede hacer clic en el campo para deshabilitarlo.

    
respondido por el ateymuri 26.08.2016 - 20:05
0

Agrego

"/etc/init.d/bluetooth stop"

en

"/etc/rc.local" 

antes del comando "exit 0" para arrancar con bluetooth apagado.

    
respondido por el Saeed Zarinfam 23.08.2012 - 15:05
0

Solución para mi portátil

"BIOS - Configuración USB - EHCI2: deshabilitado"

EHCI1 es para puertos usb (en realidad Mi portátil tiene 2 puertos usb 2.0)

    
respondido por el MSP 27.03.2014 - 19:46
0

Editar /etc/default/grub :

sudo nano /etc/default/grub

y cambie la siguiente línea:

GRUB_CMDLINE_LINUX=""

para decir esto en su lugar:

GRUB_CMDLINE_LINUX="bluetooth.blacklist=yes"

Luego, actualiza grub y reinicia:

sudo update-grub
    
respondido por el mchid 21.09.2015 - 07:58
0

Esto debería deshabilitar que bluetooth no se inicie en sistemas basados ​​en Debian:

sudo chkconfig bluetooth off

o en sistemas basados ​​en RedHat

systemctl disable bluetooth.service
    
respondido por el Stanislav 16.10.2017 - 22:18
0

Si está utilizando el applet de Bluetooth en el panel superior (blueman-applet), tiene su propia configuración que activará automáticamente Bluetooth incluso si lo ha desactivado en otros lugares (como / etc / bluetooth / main .conf o / etc / default / tlp).

Para evitar que Bluetooth se encienda al inicio con la línea de comando:

gsettings set org.blueman.plugins.powermanager auto-power-on false

O a través de la GUI:

  1. Haz clic en el applet de Bluetooth & gt; Complementos & gt; PowerManager & gt; Configuración
  2. Desmarque Encendido automático

La próxima vez que reinicie, el applet de Bluetooth seguirá estando visible, pero Bluetooth estará apagado. Para activarlo:

Haga clic en el applet de Bluetooth & gt; Activar Bluetooth

    
respondido por el bmaupin 27.07.2018 - 19:12
-1

Tuve que usar un método de fuerza bruta para evitar que bluetoothd se inicie automáticamente en el arranque. Cambié el nombre del archivo ejecutable para que no se pudiera encontrar.

    
respondido por el bluesdiva2001 06.07.2012 - 03:02
-1

También puede usar esta aplicación gráfica que también hace esto bluetooth manager

    
respondido por el deFreitas 27.12.2014 - 14:26
-3

Debe deshabilitarlo desde la lista de Aplicaciones de inicio en Configuración del sistema.

Haga clic en el engranaje en la parte superior derecha de la barra de menú y luego seleccione Configuración del sistema.

Haz clic en Start Up Applications y desplázate hacia abajo hasta que encuentres la configuración del bluetooth, toma la marca del cuadro y listo.

    
respondido por el Mark Rooney 16.10.2011 - 23:13

Lea otras preguntas en las etiquetas