Los enlaces externos se abren como pestañas en blanco en la nueva ventana del navegador en Chrome

109

Desde que instalé Ubuntu (nueva instalación en una máquina nueva) y configuré Google Chrome como navegador predeterminado, cada vez que abro enlaces de aplicaciones externas, estos se abren como pestañas en blanco en la nueva ventana del navegador (no hay una redirección real al sitio, solo una pestaña en blanco).

Cambié a Firefox y este comportamiento no persiste. Si cambio de nuevo a Chrome como navegador predeterminado (a través de las aplicaciones predeterminadas), vuelve a suceder.

Noté que tanto en Unity Launcher como en la configuración predeterminada de la aplicación, Chrome no se llama solo 'Google Chome' sino 'New Tab - Google Chrome'. No estoy seguro de si esto está relacionado o cómo solucionarlo. Hice algunas búsquedas que sugieren buscar mimeapps.list o verificar que google-chrome-stable.desktop contenga un valor de% U, pero ninguno de estos ayudó.

Por cierto, este es un extracto de la entrada .desktop:

[Desktop Entry]
Version=1.0
Name=Google Chrome
Exec=/usr/bin/google-chrome-stable %U
Terminal=false
Icon=google-chrome
Type=Application
Categories=Network;WebBrowser;
MimeType=text/html;text/xml;application/xhtml_xml;image/webp;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/ftp;
X-Ayatana-Desktop-Shortcuts=NewWindow;NewIncognito

esto es mimeapps.list

[Default Applications]
text/html=google-chrome.desktop
x-scheme-handler/http=google-chrome.desktop
x-scheme-handler/https=google-chrome.desktop
x-scheme-handler/about=google-chrome.desktop
x-scheme-handler/unknown=google-chrome.desktop
    
pregunta unfulvio 24.10.2015 - 20:53

2 respuestas

203

Como dijo unfulvio, el problema es con google-chrome.desktop , y falta el argumento %U .

Abrir archivo: $HOME/.local/share/applications/google-chrome.desktop

Encuentra la línea:

Exec=/opt/google/chrome/chrome

Agregue un espacio y %U :

Exec=/opt/google/chrome/chrome %U

Luego guarda el archivo.

    
respondido por el LostNomad311 24.11.2015 - 02:01
9

Creo que lo resolví eliminando esta entrada de .desktop:

rm $HOME/.local/share/applications/google-chrome.desktop

que tenía el nombre erróneo New Tab - Google Chrome y era responsable del nuevo comportamiento de ventana / pestaña descrito en mi pregunta original

Tuve que volver a crear el icono de la aplicación después de eso, aunque

    
respondido por el unfulvio 25.10.2015 - 16:45

Lea otras preguntas en las etiquetas