¿Cómo desactivo la sesión de invitado?

181

¿Cómo desactivo la sesión de invitado en Ubuntu 11.10 o superior? ¡No quiero que la gente pueda usar mi computadora sin usar una contraseña para iniciar sesión!

    
pregunta Jeremy Bicha 22.09.2011 - 17:45

12 respuestas

117

Actualizado: 2016-agosto

para Ubuntu 16.04 LTS (15.10 o posterior)

Adaptado de: Wiki de LightDM Ubuntu - Configuración

  • Los archivos de configuración proporcionados por el sistema en /usr/share/lightdm/ no son intencionales para ser editables por el usuario. En cambio, los usuarios deberían usar: /etc/lightdm/
  • Las versiones más recientes de LightDM (Ubuntu 15.10, o posterior) usan [Seat:*] en lugar de [SeatDefaults]

Simplemente ejecuta esto (una vez) en la terminal:

sudo sh -c 'printf "[Seat:*]\nallow-guest=false\n" >/etc/lightdm/lightdm.conf.d/50-no-guest.conf'

Para deshacer (restaurar la opción Invitado), eliminar el archivo creado :

sudo rm /etc/lightdm/lightdm.conf.d/50-no-guest.conf

para Ubuntu 14.04 LTS (hasta 15.04)

Adaptado de: Ubuntu Forums - ubicación de los archivos de configuración lightdm en 14.04

Simplemente ejecuta esto (una vez) en la terminal:

sudo sh -c 'printf "[SeatDefaults]\nallow-guest=false\n" >/usr/share/lightdm/lightdm.conf.d/50-no-guest.conf'

Ya no tendrá la opción de "Invitado" como inicio de sesión en su próximo inicio de sesión.

Para deshacer (restaurar la opción Invitado), eliminar el archivo creado :

sudo rm /usr/share/lightdm/lightdm.conf.d/50-no-guest.conf

Para Ubuntu 12.04 LTS (hasta 13.10)

Método más simple.

Simplemente ejecuta esto (una vez) en la terminal:

sudo /usr/lib/lightdm/lightdm-set-defaults -l false

Ya no tendrá la opción de "Invitado" como inicio de sesión en su próximo inicio de sesión.

  • Esto simplemente agrega allow-guest=false a /etc/lightdm/lightdm.conf .

  • Debería funcionar desde 11.10 en adelante (ya que estos también usan LightDM ).

Para deshacer (restaurar la opción Invitado):

sudo /usr/lib/lightdm/lightdm-set-defaults -l true
    
respondido por el david6 28.07.2012 - 01:38
115
  

Usa este método únicamente si estás utilizando Ubuntu Desktop. Si está utilizando otro sabor como Xubuntu o Lubuntu, consulte en su lugar esta respuesta .

Si está utilizando LightDM predeterminado, edite /etc/lightdm/lightdm.conf para que se vea así:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
allow-guest=false

Si está utilizando GDM (que era el predeterminado en las versiones anteriores de Ubuntu), desinstale gdm-guest-session .

Para Ubuntu 13.10 a 14.10 , el archivo se movió a /etc/lightdm/lightdm.conf.d/50-unity-greeter.conf

Para Ubuntu 14.10 o superior, el archivo se ha movido a /usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf

    
respondido por el Jeremy Bicha 22.09.2011 - 17:48
24

Escribe esto en la terminal

gksu gedit /etc/lightdm/lightdm.conf

Verá lo siguiente:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu

Agregue allow-guest=false al final para que su resultado final se vea así:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
allow-guest=false

Guarde el documento y salga del editor de texto.

De vuelta en la Terminal, reinicie el administrador de pantalla. (Esto finalizará la sesión de inicio de sesión gráfica, abandonando de inmediato todos los programas que se ejecutan en ella, así que asegúrese de que su trabajo, como cualquier documento abierto, se guarde primero).

sudo restart lightdm

Con la sesión de inicio de sesión gráfica finalizada, vuelve a la pantalla de inicio de sesión, donde notará que la cuenta de invitado está deshabilitada.

Eso es todo: la cuenta de invitado ya no se puede usar.

    
respondido por el sarveshlad 25.10.2011 - 03:08
17

Puedes hacerlo usando Ubuntu Tweak .

Para instalarlo, use estos comandos:

sudo add-apt-repository ppa:tualatrix/ppa
sudo apt-get update
sudo apt-get install ubuntu-tweak

Después de la instalación, vaya a Ajustes → Configuración de inicio de sesión y desactive la "Cuenta de invitado".

    
respondido por el Eliran Malka 21.10.2012 - 19:54
11

Solo ejecuta

gksudo gedit /etc/lightdm/lightdm.conf

Agregue la siguiente línea

allow-guest=false

Luego (esto lo desconectará inmediatamente, saldrá de todos los programas que se ejecutan en su sesión gráfica, así que primero guarde su trabajo):

sudo restart lightdm
    
respondido por el LnxSlck 27.07.2012 - 18:42
4

Cómo deshabilitar esta opción en el futuro

Acabo de encontrar el mismo problema en mi nueva instalación de trusty / 14.04. También para mi sorpresa, no pude encontrar la carpeta lightdm.conf.d dentro de /etc/lightdm/ just users.conf .

Investigación

$ find / -iname *lightdm* 2>/dev/null | grep -v /mnt | grep -v /media | grep -v /home
[...]
/usr/share/lightdm/lightdm.conf.d
[...]

Aha, ahí estás. ¿Qué hay ahí?

$ ls -1 /usr/share/lightdm/lightdm.conf.d/
50-greeter-wrapper.conf
50-guest-wrapper.conf
50-ubuntu.conf
50-unity-greeter.conf
50-xserver-command.conf

Bien, ¿qué hay ahí?

$ cat /usr/share/lightdm/lightdm.conf.d/*
[SeatDefaults]
greeter-wrapper=/usr/lib/lightdm/lightdm-greeter-session
[SeatDefaults]
guest-wrapper=/usr/lib/lightdm/lightdm-guest-session
[SeatDefaults]
user-session=ubuntu
[SeatDefaults]
greeter-session=unity-greeter
[SeatDefaults]
# Dump core
xserver-command=X -core

Conclusión

Encontramos un grupo de archivos de configuración similares al formato INI siguiendo el esquema de nombres de 50-${some-descriptive-name}.conf y configurando claves para la sección [SeatDefaults] .

No vamos a editar ninguno de estos archivos ya que están destinados a ser administrados por el administrador de paquetes, pero ahora cómo debemos agregar y administrar nuestros bits de configuración personalizados a /etc .

Solución

Dado lo anterior, ese lightdm es el administrador de pantalla y los archivos de configuración se ven como los de arriba. La siguiente solución debería funcionar:

  1. Crea los directorios faltantes:

    $ sudo mkdir -p /etc/lightdm/lightdm.conf.d
    
  2. Agregue un archivo de configuración personalizado ejecutando:

    $ sudo nano /etc/lightdm/lightdm.conf.d/50-disable-guest-session.conf
    

    y pegue las siguientes líneas:

    [SeatDefaults]
    allow-guest=false
    

    Luego, guarde ( Ctrl + O ) y cierre ( Ctrl + X ).

  3. Ahora cierre la sesión y cambie a una terminal virtual ( Ctrl + Alt + F1 ), luego ejecute:

    $ sudo service lightdm restart
    

    La opción de sesión de invitado debería desaparecer. Si algo no funciona del todo bien, ahora sabe dónde está almacenada la configuración predeterminada y que no la cambió.

Lectura adicional

respondido por el LiveWireBT 16.03.2014 - 03:32
3

Para Ubuntu 13.10 , agregue

allow-guest=false

al archivo /etc/lightdm/lightdm.conf.d/10-ubuntu.conf .

    
respondido por el uahummer 20.10.2013 - 15:27
3

13.04 y posterior

  1. Ejecuta este comando en un terminal

    sudo /usr/lib/lightdm/lightdm-set-defaults -l false
    
  2. Reinicia tu máquina o reinicia lightdm con el siguiente comando
    (Esto te desconectará inmediatamente, guarda tus datos)

    sudo restart lightdm
    

Aparentemente, funciona en 13.10 (no puedo probarme, pero hay un comentario aquí ).

Estoy usando 13.04 y todo esto agrega allow-guest=false a /etc/lightdm/lightdm.conf , pero podría ser diferente en 13.10.

Originalmente por david6 desde aquí: enlace

    
respondido por el kiri 21.10.2013 - 09:33
2

Instala ubuntu-tweak, ve a la pestaña de ajustes, apaga el botón de invitado y reinicia. ¡Eso es!

Uno puede encontrar el terminal más fácil, pero en caso de que surja la necesidad de activar la cuenta de invitado, entonces uno debería visitar esta página nuevamente y ver las instrucciones (o más bien deshacer). Esa es la ventaja de la interfaz gráfica de usuario ... uno lo recuerda fácilmente.

    
respondido por el tadatma 27.09.2012 - 19:33
2

Cambiar allow-guest=true a 'false' en /etc/lightdm/lightdm.conf

Luego puede reiniciar o reiniciar el servicio en la terminal:

sudo restart lightdm

Suponiendo que está utilizando lightdm que es estándar en 11.10.

    
respondido por el filescraps 21.10.2011 - 12:42
0

Estoy en el mismo caso, el archivo /etc/lightdm/lightdm.conf no existe en UBUNTU 13.10.

Intento crear el archivo /etc/lightdm/lightdm.conf con esta línea allow-guest=false y CRASH, el sistema no se inicia correctamente, solo el modo de consola ...

Intento editar el archivo /etc/lightdm/lightdm.conf.d/10-ubuntu.conf y funciona correctamente.

Editar el archivo

sudo vim /etc/lightdm/lightdm.conf.d/10-ubuntu.conf

Y ingrese las líneas que necesita

# to disable guest login
allow-guest=false
# to enable user login manually
greeter-show-manual-login=true

Y el último, reinicia tu sistema

sudo reboot

Creo que esto funciona bien si reinicias solo el ligthgdm

sudo service lightdm restart
    
respondido por el Foncu 23.10.2013 - 16:05
0

Abrir terminal

gksudo gedit /etc/lightdm/lightdm.conf

Agregue la siguiente línea

allow-guest=false

Guarde y salga del archivo.

    
respondido por el scouser73 21.10.2013 - 09:29

Lea otras preguntas en las etiquetas