Wifi no funciona después de suspender después de la actualización 16.04

136

Esta versión en particular de "no funciona después de suspender" se produjo después de actualizar a 16.04. Parece que la actualización incluye un applet Wicd (agregado a la barra de tareas de Metacity Classic Gnome junto con el ícono de red normal), pero parece que no funciona después de una suspensión. Un sudo service network-manager restart duplica este problema. Se necesita un reinicio completo para que Wi-Fi vuelva a funcionar. ¿Alguna idea de por qué?

    
pregunta 147pm 23.04.2016 - 13:42

10 respuestas

164

16.04 se ejecuta en systemd. Intenta lo siguiente:

sudo systemctl restart network-manager.service

Si esto funciona, puedes crear un script para automatizarlo.

Abra un terminal y escriba lo siguiente:

sudo nano /etc/systemd/system/wifi-resume.service Ahora pegue el script allí con un clic derecho. Salga con CTRL + X y presione Y para guardar. Ahora para activarlo: sudo systemctl enable wifi-resume.service

Script:

#/etc/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart networkmanager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Espero que esto ayude. Funciona en mi computadora portátil.

    
respondido por el Joakim Koed 23.04.2016 - 15:17
10

@ 147pm ¿Alguna vez hiciste funcionar esto?

Descubrí que tenía un problema bastante similar, aunque estoy en Kubuntu 16.10 (basado en KDE, no en Gnome) y con una computadora portátil HP ProBook. Y, a diferencia de usted, no fue mi Wifi el que murió después de la suspensión / activación, sino mi puerto Ethernet. Aún así, me pregunto si están relacionados.

También veo que no tiene el problema en KDE. Pero me gustaría saber si la solución a continuación ayuda con Gnome, ya que la solución no se basa en el administrador de ventanas, el entorno de escritorio o los applets.

Primero, solo para confirmar que reinicie el servicio del administrador de red ...

$ sudo systemctl restart network-manager.service

no funcionó para mí.

Sin embargo, encontré una respuesta que funcionó, gracias a la pregunta y la información de buzhidao en no se puede conectar a Internet después de suspender y el comentario de GAD3R allí.

Usando su información, encontré que primero investigar qué hardware y controlador / módulo Ethernet estoy ejecutando, y luego quitar y volver a instalar ese módulo, funcionó para mí (aunque no lo hizo para buzhidao):

Wifi:

$ lspci -knn | grep Net -A2

Ethernet:

$ lspci -knn | grep Ether -A2

El segundo de estos (Ethernet) fue lo que usé, y encontré:

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c)
        Subsystem: Hewlett-Packard Company RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [103c:1944]
        Kernel driver in use: r8169
        Kernel modules: r8169

entonces reinstalé el controlador 'r8169':

$ sudo rmmod r8169 && sudo modprobe r8169

y voila! Esto funciono Mi puerto / conexión Ethernet volvió a estar activo (después de suspender / activar) sin tener que reiniciar.

(Tampoco tuve un dispositivo wifi Realtek, sino un Qualcomm Atheros (mod: ath9k) que tal vez explique por qué wifi siguió funcionando para mí después de despertar de mi suspensión)

Como se puede ver en mi comentario en esa otra publicación, me pregunté si el problema es el elemento común entre Buzhidao y yo: los dispositivos Realtek Semiconductor. ¿Aunque usen módulos diferentes, podrían compartir algún código común? ¿O incluso ser tratado de manera diferente por el nuevo código del kernel ahora de alguna manera?

¿Tienes un dispositivo wifi basado en Realtek? (usando lspci arriba)? ¿Tienes suerte al reinstalar el módulo (rmmod / modprobe arriba)?

De todos modos, solo un tiro en la oscuridad. Si ha encontrado una respuesta final para usted, háganoslo saber. Thx.

    
respondido por el androclus 16.03.2017 - 23:40
6

Para reiniciar automáticamente NetworkManager después de reanudar en un entorno sin acceso sudo , cree un script en /etc/pm/sleep.d (cualquier nombre), establezca el bit ejecutable a través de chmod +x e inserte el siguiente contenido:

case "${1}" in
    resume|thaw)
        # systemctl restart network-manager.service
        service NetworkManager restart
;;
esac

Para mí, la línea service funcionó, pero systemctl puede funcionar mejor para ti.

Fuente: enlace .

    
respondido por el krlmlr 05.11.2016 - 08:50
2

Para mí, parece ser aleatorio, pero a veces el wifi simplemente se desconecta si estoy conectado, o no muestra redes si no lo estoy. A veces, poner mi computadora portátil en modo de suspensión parece activarlo, pero no siempre.

Por lo general, una combinación de estos hace que vuelva a funcionar sin reiniciar:

  • sudo iwlist $(ifconfig | grep -Po '^w\w+') scan
  • %código%
    • Simplemente llamar a sudo service network-manager stop; sleep 5; sudo service network-manager start aquí nunca parece funcionar para mí. Parece que intenta iniciarlo antes de que termine de apagarlo, por lo tanto, tengo más suerte al hacer una pausa entre restart y stop .
  • Desactivar wifi en la interfaz de usuario; espera unos segundos; volver a encenderlo

Ninguno de esos parece funcionar de manera consistente, pero primero los enumeré en orden de probabilidad de éxito.

    
respondido por el redbmk 20.12.2016 - 17:07
2

Método de trabajo en Ubuntu 16.04:

Crea el servicio: sudo nano /lib/systemd/system/wifi-resume.service

El servicio está llamando al programa desde:
/etc/init.d/network-manager

Pegue el código:

#/lib/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart network-manager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target 

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Luego habilita el servicio:

sudo systemctl enable /lib/systemd/system/wifi-resume.service

Esto crea los enlaces simbólicos en los directorios [Instalar] indicados de / etc / systemd / system y activa el servicio

Después, puede verificar el estado con: systemctl status wifi-resume.service

    
respondido por el cryptoboy 23.01.2017 - 01:59
1

Tuve el mismo problema con el bluetooth: después de suspender, mi mouse bluetooth no funcionó. Así que derivé la solución de arriba:

sudo nano /etc/systemd/system/bluetooth-resume.service

habilitó el nuevo servicio

sudo systemctl enable bluetooth-resume.service

y editado el servicio

#/etc/systemd/system/bluetooth-resume.service
#sudo systemctl enable bluetooth-resume.service
[Unit]
Description=Restart bluethooth at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart bluetooth.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

También intenté editar ...

sudo nano /etc/bluetooth/main.conf

y cambiado

AutoEnable=true

¡PERO esto no funcionó para el "problema de reanudación" y no tuvo ningún impacto en los nuevos dispositivos bluetooth de todos modos!

    
respondido por el apos 31.08.2016 - 13:11
1

Tuve el mismo problema en mi computadora portátil Dell Inspiron 15R con Ubuntu 16.04. Para mí, trabajé el script informado en la segunda respuesta .

Después de haber instalado el script, probé la suspensión con el comando en el menú superior derecho e incluso cerrando el borde, resolviendo el problema.

Tengo que decir que el problema fue alternar en su comportamiento (es decir, algunas veces funcionó antes de instalar el script).

    
respondido por el Alessandro D'lncal 18.01.2017 - 15:58
0

Para mí, la solución fue ejecutar

nmcli nm sleep false

en una terminal

    
respondido por el tigerjack89 08.04.2017 - 13:01
0

Tuve el mismo problema al volver a conectarme a la wifi de mi casa después de suspender. Probé las otras respuestas sugeridas que ocasionalmente funcionarían pero no siempre.

Finalmente, la siguiente solución permitió la conexión constante a la wifi:

1) Edita este archivo:

sudo vim /etc/NetworkManager/NetworkManager.conf

2) Añadiéndole esto:

[device]
wifi.scan-rand-mac-address=no
    
respondido por el Ray Vega 28.03.2018 - 08:09
0

Ahora probablemente simple

sudo apt update
sudo apt upgrade

debería funcionar.

En mi caso, entre los paquetes actualizados, hubo bcmwl-kernel-source (6.30.223.271+bdcom-0ubuntu1~1.3) y, después de esta actualización, el wifi vuelve a funcionar.

    
respondido por el Daniel 05.08.2018 - 07:08

Lea otras preguntas en las etiquetas