No hay más actualizaciones para Google Chrome de 32 bits

106

Estoy usando Google Chrome 48.0 de 32 bits. Hoy cuando lancé Google Chrome, recibí este mensaje:

This computer will soon stop receiving Google Chrome updates because
this Linux system will no longer be supported

Pensé que Ubuntu 14.04 es compatible durante cinco años, ¿qué está pasando exactamente aquí?

Y en Ubuntu de 64 bits, recibo un error de Update Manager y apt-get update :

Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release 
Unable to find expected entry 'main/binary-i386/Packages' in Release file
(Wrong sources.list entry or malformed file)  
Some index files failed to download.  
They have been ignored, or old ones used instead.  
    
pregunta Parto 22.01.2016 - 07:26

7 respuestas

126

¡Información importante sobre cómo instalar Chrome en Ubuntu 16.04 y 17.04 en la parte inferior!

Este mensaje es válido solo para sistemas Linux de 32 bits, por supuesto, los sistemas de 64 bits seguirán siendo compatibles. Cuando tenga instalada la versión de 32 bits de Ubuntu, Google Chrome no recibirá actualizaciones a partir de marzo de 2016; esto ya fue anunciado por Google el 1 de diciembre de 2015.

Google: finalizaremos el soporte para Google Chrome en Linux de 32 bits, Ubuntu Precise (12.04) ...

Cuando desee recibir actualizaciones de Chrome, debe cambiar a la versión de 64 bits de Ubuntu. Ubuntu 14.04.3 LTS y Ubuntu 15.10 se recomiendan para descargar en sabor de 64 bits de todos modos. La próxima edición Ubuntu LTS 16.04 Xenial Xerus se lanzará en abril de 2016, instálala en 64 bits.

En el marco de tiempo de marzo a abril, puede usar el navegador web Firefox preinstalado. Alternativamente, puede instalar Chrome-browser o epiphany-browser desde los repositorios de Ubuntu. O puede instalar la versión de 64 bits de Ubuntu 14.04, pero ¿vale la pena el esfuerzo? ... tú decides ...

El soporte de cinco años para las ediciones Ubuntu LTS cubre el sistema, incluidos los repositorios oficiales. Google Chrome no está disponible en los repositorios oficiales de Ubuntu y esa es la razón por la cual no hay soporte LTS de cinco años para Chrome proporcionado por los desarrolladores de Canonical / Ubuntu.

Actualizar información 2016-03-03: ¡Google ha eliminado la versión de 32 bits de su repositorio!

Como puede ver en el sitio web de Google Chrome , no hay una edición de Linux de 32 bits ofrecido más.

Ejecutando sudo apt-get update da el siguiente error:

Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release 
Unable to find expected entry 'main/binary-i386/Packages' in Release file
(Wrong sources.list entry or malformed file)  
Some index files failed to download.  
They have been ignored, or old ones used instead.  

Como solución, establezca los repositorios específicamente para 64 bits:

sudo sed -i -e 's/deb http/deb [arch=amd64] http/' "/etc/apt/sources.list.d/google-chrome.list" "/opt/google/chrome/cron/google-chrome"

Referencia: Corregir "No se pudo recuperar" el repositorio de Google Chrome

Actualizar información 2016-03-09: Google parece haber solucionado el problema en la versión 49.0.2623.87.

/opt/google/chrome/cron/google-chrome file ahora tiene estas entradas relevantes de arquitectura:

# sources.list setting for google-chrome updates.
REPOCONFIG="deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main"
REPOCONFIGREGEX="deb (\[arch=[^]]*\bamd64\b[^]]*\][[:space:]]*)?https?://dl.google.com/linux/chrome/deb/ stable main"
El archivo

/etc/apt/sources.list.d/google-chrome.list muestra esta entrada relevante de arquitectura:

### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

Actualizar información 2016-04-21: Cómo instalar el navegador Google Chrome en Ubuntu 16.04

Actualmente existe un problema para instalar Google Chrome al descargar desde el sitio web de Google. Al hacer clic en el archivo .deb , se abre el software de Ubuntu, pero no ocurre nada al hacer clic en Instalar. Instale Google Chrome correctamente de esta manera: abra un terminal y ejecute los siguientes comandos:

echo "deb http://dl.google.com/linux/chrome/deb/ stable main" | sudo tee /etc/apt/sources.list.d/google-chrome.list  
wget -q -O - https://dl.google.com/linux/linux_signing_key.pub | sudo apt-key add -  
sudo apt-get update
sudo apt-get install google-chrome-stable

Hay poco nuevo problema de "firma débil" al actualizar los repositorios, pero se puede ignorar:

W: http://dl.google.com/linux/chrome/deb/dists/stable/Release.gpg: Signature by key 4CCA1EAF950CEE4AB83976DCA040830F7FAC5991 uses weak digest algorithm (SHA1)  

Información de actualización 2017-04-13: Cómo instalar el navegador Google Chrome en Ubuntu 17.04

Los comandos anteriores para Ubuntu 16.04 siguen siendo válidos y la mejor solución de trabajo para instalar Google Chrome con éxito. Nota: el comando apt se puede usar en lugar de apt-get también.

    
respondido por el cl-netbox 22.01.2016 - 11:23
29

Lo que sucede es que la palabra "compatible" en este mensaje no significa lo que piensas que significa. Cuando Google dice "este sistema ya no será compatible", lo que dicen es "dejaremos de proporcionar actualizaciones de Chrome para este sistema". Por otro lado, cuando Canonical dice "Ubuntu 14.04 tendrá soporte durante cinco años", lo que dicen es "paquetes en los repositorios oficiales recibirá actualizaciones durante cinco años". Debido a que los paquetes de Chrome no están en los repositorios oficiales de Ubuntu, no hay contradicción entre los dos.

    
respondido por el fkraiem 22.01.2016 - 11:57
20

EDITAR: Parece que Google ha agregado los cambios correctos a las actualizaciones. Entonces, simplemente arreglar la línea de repositorio, luego ejecutar la actualización debería ser bueno a partir de ahora.

Google detuvo el soporte de 32 bits de Chrome para Linux. Curiosamente, en el sitio de descarga de Google Chrome , todavía tienen el enlace a la versión de 32 bits.

Para solucionarlo, realice los siguientes cambios:

(Opcional) Primero, elimine Google Chrome y el archivo del repositorio: No se preocupe, su configuración aún debería estar segura.

sudo apt-get remove google-chrome-stable
sudo rm /etc/apt/sources.list.d/google-chrome.list*

Luego actualiza el sistema:

sudo apt-get update

A continuación, arregle los siguientes comandos del archivo de repositorio de Google Chrome:

Agregue la clave: Solo si esta es una instalación por primera vez.

wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -

Luego agregue los cambios al repositorio:

sudo sh -c 'echo "deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main" > /etc/apt/sources.list.d/google-chrome.list'

Si Google Chrome ya está instalado:

sudo apt-get update
sudo apt-get upgrade

Si no está instalado:

sudo apt-get update
sudo apt-get install google-chrome-stable

¡Espero que esto ayude!

    
respondido por el Terrance 06.03.2016 - 04:58
13

Cambia a Chromium: es prácticamente idéntico (incluso te permite iniciar sesión en Google al igual que Chrome), fuente totalmente abierta y provisto por los repositorios de Ubuntu.

Para obtener asistencia técnica con Chromium, siga estas instrucciones.

    
respondido por el Keith 22.01.2016 - 10:20
6

Lea enlace

A partir de ahí:

  

Para proporcionar la mejor experiencia para las versiones de Linux más utilizadas,   terminará el soporte para Google Chrome en Linux de 32 bits, Ubuntu Precise   (12.04) y Debian 7 (wheezy) a principios de marzo de 2016. Chrome lo hará   continuará funcionando en estas plataformas pero ya no recibirá   actualizaciones y correcciones de seguridad.

     

Tenemos la intención de seguir apoyando las configuraciones de compilación de 32 bits en   Linux para apoyar la construcción de Chromium. Si usa Precise, tendríamos   Le recomendamos que actualice a Trusty.

    
respondido por el DK Bose 22.01.2016 - 11:22
4

En Ubuntu de 64 bits, escriba los siguientes comandos:

sudo sed -i -e 's/deb http/deb [arch=amd64] http/' "/etc/apt/sources.list.d/google-chrome.list"

Y

sudo sed -i -e 's/deb http/deb [arch=amd64] http/' "/opt/google/chrome/cron/google-chrome"

Paquete de actualización: sudo apt-get update

De acuerdo con webupd8 En el sistema operativo de 64 bits que necesita para editar los dos archivos siguientes:

/etc/apt/sources.list.d/google-chrome.list

Cambiar línea # 3 de:

deb http://dl.google.com/linux/chrome/deb/ stable main

a:

deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

Editar /opt/google/chrome/cron/google-chrome

Cambiar REPOCONFIG y SSLREPOCONFIG desde:

REPOCONFIG="deb http://dl.google.com/linux/chrome/deb/ stable main"
SSLREPOCONFIG="deb https://dl.google.com/linux/chrome/deb/ stable main"

Para

REPOCONFIG="deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main"
SSLREPOCONFIG="deb [arch=amd64] https://dl.google.com/linux/chrome/deb/ stable main"

Actualización del 3 de agosto de 2016 :

Para instalar la última versión de Google Chrome 50 (64 bits) en Ubuntu 16.04 LTS a través de PPA con buenas firmas:

Descargar la clave pública de Google:

wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -

Añadir repositorio de Google Chrome:

sudo sh -c 'echo "deb http://dl.google.com/linux/chrome/deb/ stable main" > /etc/apt/sources.list.d/google.list'

Actualización del repositorio:

sudo apt update

o

sudo apt-get update

Instalar Google Chrome:

sudo apt install google-chrome-stable

o

sudo apt-get install google-chrome-stable
    
respondido por el GAD3R 05.03.2016 - 15:31
1

De acuerdo con enlace , haga lo siguiente desde símbolo del sistema:

sudo sed -i -e 's/deb http/deb [arch=amd64] http/' "/etc/apt/sources.list.d/google-chrome.list"

sudo sed -i -e 's/deb http/deb [arch=amd64] http/' "/opt/google/chrome/cron/google-chrome"

Tenga en cuenta que según la fuente anterior, "este archivo se cambia en cada actualización de Google Chrome y parece que no hay forma de evitarlo (cambiando / opt / google / chrome / cron / google-chrome o / etc / default / google -chrome no afecta esto) así que hasta que Google cambie esto en su paquete, necesitarás aplicar la corrección anterior después de cada actualización de Google Chrome .... Una solución alternativa sería hacer que el archivo .list sea inmutable, por lo que puede No se modifique por ninguna actualización de Google Chrome, utilizando "sudo chattr + i /etc/apt/sources.list.d/google-chrome.list" (que puede revertirse usando: "sudo chattr -i / etc / apt /sources.list.d/google-chrome.list ") pero esto no es ideal y deberías cambiar este archivo una vez que Google solucione esto por su parte."

    
respondido por el m2web 09.03.2016 - 10:54

Lea otras preguntas en las etiquetas