16.04 problemas de conexión wifi LTS con el adaptador Realtek

116

Descubrí varios problemas con la conexión wifi después de instalar 16.04 LTS.

Primero, wifi no se vuelve a conectar normalmente después de dormir o hibernar. A veces, el ícono de la red se convierte en una "flecha hacia arriba y hacia abajo" (no sé para qué sirve) después de despertarse, pero todavía está conectado. A veces, la red simplemente se pierde y no muestra ninguna red en la lista, por lo que simplemente no hay forma de usar wifi.

Primero intenté reiniciar el administrador de red ejecutando sudo service network-manager restart . Funcionó, pero no fue una resolución permanente.

Luego, según otro hilo, agregué SUSPEND_MODULES="iwlwifi" a

/etc/pm/config.d/config

Después de hacer esto, el problema de reconexión parece ser fijo (puede reconectarse automáticamente y el ícono ya no cambia). Sin embargo, encuentro que la conexión wifi se pierde al azar (aproximadamente cada 30 minutos) incluso cuando la computadora está funcionando y el ícono de red permanece en estado conectado cuando se pierde la conexión.

Otro problema después de agregar el código es que cuando apago la computadora, la pantalla se apaga por un segundo y luego se vuelve a encender durante unos 5 segundos (durante los cuales el sistema cortará la conexión wifi). Y luego la computadora se irá a dormir después de este inusual proceso de "dos fases".

Por favor encuentre la información de la tarjeta inalámbrica a continuación

*-network               
       description: Wireless interface
       product: RTL8723BE PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: [email protected]:02:00.0
       logical name: wlp2s0
       version: 00
       serial: b0:c0:90:5c:1c:d5
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723be driverversion=4.4.0-21-generic firmware=N/A ip=192.168.0.8 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 ioport:d000(size=256) memory:df200000-df203fff

00:00.0 Host bridge: Intel Corporation Sky Lake Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Sky Lake PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Sky Lake Integrated Graphics (rev 06)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #1 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #9 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (2) I219-V (rev 31)
01:00.0 VGA compatible controller: NVIDIA Corporation GK208 [GeForce GT 730] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GK208 HDMI/DP Audio Controller (rev a1)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
03:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller (rev 01)

01/05/2016 Actualización: No sé lo que pasó, pero el problema empeora ahora. La conexión wifi se pierde cada 5 minutos y tengo que volver a conectarme o reiniciar el administrador de red.

    
pregunta Lixu 25.04.2016 - 07:13

9 respuestas

44

Finalmente pude solucionar los problemas después de probar números de diferentes métodos.

  1. Obtenga detalles de su tarjeta inalámbrica PCI ejecutando sudo lshw -class network
  2. Obtenga la información del modelo de su tarjeta de acuerdo con la línea de productos.
    Por ejemplo, como puede ver en la descripción de la pregunta, dice: product: RTL8723BE PCIe Wireless Network Adapter , por lo que el modelo de mi tarjeta es RTL8723BE

    O product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller para que el modelo de mi tarjeta sea RTL8101/2/6E

  3. Dar el permiso sudo chmod 755 /etc/pm/config.d/

  4. Abra o cree config y agregue SUSPEND_MODULES="rtl8723be" (reemplace rtl8723be con su propio número de modelo)
    Entonces ejecute
    echo "options rtl8723be fwlps=N" | sudo tee /etc/modprobe.d/rtl8723be.conf
    (Tenga en cuenta que al reemplazar rtl8723be con mi tarjeta, que es RTL8101/2/6E , solo debería escribir .../modprobe.d/RTL8101.conf y /2/6E no debe escribirse)

Finalmente reinicia tu sistema.

Ahora su sistema debería poder volver a conectarse automáticamente después de dormir, y la conexión wifi nunca se perdió una sola vez después de hacer esto.

"Las flechas arriba / abajo es probablemente una falla del administrador de red que hace que el administrador de la red piense que el dispositivo wifi es en realidad ethernet", de acuerdo con Jeremy31. vea la información del error aquí Debería poder arreglarlo instalando NetworkManager-1.2.0.

Gracias a Jeremy31 por proporcionar las soluciones.

    
respondido por el Lixu 06.05.2016 - 05:09
37

Tengo exactamente el mismo problema. Después de despertarse, el wifi todavía funciona, pero las redes no se muestran. Resuelvo el problema reiniciando el administrador de red.

sudo service network-manager restart

Aún muy molesto. Espero que solucionen este problema pronto.

    
respondido por el eldosoa 28.04.2016 - 06:25
30

Este es un error seguro. El error ha sido archivado en enlace

    
respondido por el Shinjan 02.05.2016 - 19:22
10

Información adicional: tengo el mismo problema exacto que OP describe, pero solo el problema donde el ícono nm-applet cambia a flechas y no muestra información wifi. El wifi aún funciona cuando esto sucede.

$ killall nm-applet && nm-applet & 

El truco para hacer que el ícono vuelva a aparecer, por lo que es una solución por ahora en caso de que alguien quiera ponerlo en un guión.

Puede confirmar este problema en dos computadoras separadas que ejecutan el paquete xubuntu-desktop.

Además, en ambas computadoras he ejecutado tarjetas wifi recientes. (algo parecido a AC-7260)

    
respondido por el Joel Cressy 26.04.2016 - 04:40
6

Estaba teniendo el mismo problema. Arreglé el problema de suspender el ciclo de activación creando este script en /etc/systemd/system/wifi-resume.service (el que OP publicó solo funcionó para la sesión activa ; al reiniciarlo, tuvo que ser llamado nuevamente):

#/etc/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart networkmanager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Luego solo emita este comando en la terminal para activarlo: sudo systemctl enable wifi-resume.service . Esta solución es de otra pregunta answerubuntu , y funciona tanto después de suspender como después de reiniciar.

Sin embargo, incluso después de que se arregló, obtengo el mismo comportamiento que solía suceder después de suspender cuando trato de cambiar de red wifi : el wifi está esencialmente muerto, con las dos flechas, y el applet dice " el dispositivo no está listo ". Puedo reiniciar el wifi emitiendo sudo service network-manager restart , pero no puedo cambiar de red.

¿Alguien más está experimentando esto y / o tiene una solución?

    
respondido por el Rsync 29.04.2016 - 03:20
2

Estoy usando LinxuMint 18 Mate (ubuntu16.04) y me metí en el mismo problema.

El resto anterior no funcionó para mí en mi thinkpad T440S.

La única solución alternativa que parece funcionar hasta ahora es actualizar kernel a 4.6.3

  • Vaya a este sitio web .

  • Obtenga los siguientes archivos:

    linux-headers-4.6.3-040603-generic_4.6.3-040603.201606241434_amd64.deb
    linux-headers-4.6.3-040603_4.6.3-040603.201606241434_all.deb
    linux-image-4.6.3-040603-generic_4.6.3-040603.201606241434_amd64.deb
    
  • Desde un terminal, ve a la carpeta que contiene los archivos anteriores y ejecuta:

    sudo dpkg -i *.deb
    sudo reboot
    

Si está utilizando Virtualbox, ejecute este sudo /sbin/vboxconfig

En caso de que quiera eliminarlos, ejecute:

sudo dpkg --purge linux-headers-4.6.3-040603 linux-headers-4.6.3-040603-generic 

Después de algunas pruebas más, la situación es casi la misma, tengo wifi, pero mi nm-applet no puede ver todos los WIFI a mi alrededor. Así que no estoy seguro de si esto es una buena solución: -)

    
respondido por el SteF 09.08.2016 - 11:28
2

No hay ninguna solución en este momento, pero encontré un script que me ayudó a mantener wlan:

#!/bin/bash

# Ping you most used DNS Server and reconnect on fail


while true; do
  if ! ping -c 1 -w 1 8.8.8.8 > /dev/null; then

    # with "sudo iwconfig" you can examine your name of 'wlan0'
    nmcli d connect wlan0

  fi
  sleep 2;
done

para iniciar automáticamente este script simplemente abra gnome-session-properties y agréguelo a la lista.

El guión completo (sin reconexión) se puede encontrar en esta página web .

    
respondido por el Steffomio 17.10.2016 - 21:28
1

Establezca el código de país WIFI para el dominio regulador actual de Kernels si no está configurado

iw reg get

Para configurarlo

sudo nano /etc/default/crda
REGDOMAIN=<ISOCODE>

Reiniciar

    
respondido por el Janghou 11.05.2016 - 11:34
1

solo para agregar la respuesta aceptada (con cuatro pasos)

por alguna razón, solo un paso fue suficiente para mí, incluso si no sé lo que significa:

echo "options rtl8723be fwlps=N" | sudo tee /etc/modprobe.d/rtl8723be.conf
    
respondido por el nyxee 24.09.2017 - 02:13

Lea otras preguntas en las etiquetas