¿Cómo desactivo las combinaciones de teclas F1 y F10 en gnome-terminal?

115

¿Cómo puedo desactivar las teclas F1 (ayuda) y F10 (menú de notificaciones)?

Primero necesito la utilidad de pantalla y la segunda para salir de mc en la consola.

No existen tales enlaces de teclas en los Métodos abreviados de teclado .

    
pregunta Marko Kevac 27.04.2011 - 15:55

14 respuestas

106

11.04

Desactivar el atajo de F1

  1. En un gnome-terminal abra Editar Short Atajos de teclado .

  2. Desplácese hasta el acceso directo Ayuda / Contenido , haga clic donde dice "F1" y pulse Retroceso :

Desactivar el acceso directo F10

  1. Instale el compizconfig-settings-manager paquete.

  2. Abre Administrador de configuraciones de CompizConfig .

    • Pulse Super para abrir el tablero, escriba "Compiz" y pulse Enter .
  3. Escriba "unity" en la entrada Filter y seleccione Ubuntu Unity Plugin .

  4. Haga clic en el botón a la derecha de la tecla para abrir el primer menú del panel y desmarque la casilla de verificación Habilitado .

  5. Desactivó el acceso directo global F10 , ahora deshabilita el acceso directo F10 de gnome-terminal:

    • En un gnome-terminal abra Teclados abreviados ( Editar Short atajos de teclado) y
      desmarque Habilite la tecla de método abreviado del menú (F10 de forma predeterminada)

  6. F10 está mapeado a menubar_accel por algo en Ubuntu. ¿Gnomo? ¿Metacity? No estoy seguro de qué es lo que lo roba, pero la clave no llega a Eclipse.

    • Ejecute gconf-editor, vaya a / desktop / gnome / interface y desplácese hacia abajo a menubar_accel y elimine el valor F10. [Robó desde aquí]
respondido por el Isaiah 23.06.2011 - 20:52
44

Desactiva F10 en gnome-terminal en 12.04

Escribe esto en la consola:

mkdir -p ~/.config/gtk-3.0
cat<<EOF > ~/.config/gtk-3.0/gtk.css

@binding-set NoKeyboardNavigation {
     unbind "<shift>F10"
}

* {
     gtk-key-bindings: NoKeyboardNavigation
}

EOF

Luego cierra todas las sesiones de la terminal. Ahora debería funcionar como debería (en mc por ejemplo).

respondido por el Paweł Gościcki 30.04.2012 - 21:25
23

start gconf-editor y sigue /apps/gnome-terminal/keybindings/help

Descripción:

"Tecla de acceso directo del teclado para iniciar la ayuda. Expresada como una cadena en el mismo formato utilizado para los archivos de recursos GTK +. Si establece la opción en la cadena especial" deshabilitada ", no habrá atajos de teclado para esta acción".

    
respondido por el Rinzwind 21.08.2011 - 22:28
7

Soy nuevo en Linux y esta tecla F10 me vuelve loco. Todos los trucos anteriores no funcionaron, pero ahora encontré una solución (para Ubuntu 11.10 con el escritorio clásico Gnome 3). En una terminal, ingrese el siguiente comando:

gsettings set org.gnome.desktop.interface menubar-accel ""

Con dconf-editor, se puede encontrar que el F10 realmente se ha ido. Tenga en cuenta que este tipo de trucos parecen depender en gran medida de la versión de Gnome / Ubuntu.

    
respondido por el gast128 29.11.2011 - 20:34
4

Para salir de mc (con la tecla F10). Desactivar "Tecla para abrir el primer menú del panel" en el plugin compiz de unidad (ccsm)

    
respondido por el kholis 29.04.2011 - 12:33
4

@kholis es correcto para deshabilitar F10 en Unity, pero si eres un newb como yo, necesitas un poco más de información para que esto funcione.

Si aún no está instalado, instale compizconfig-settings-manager:

sudo apt-get install compizconfig-settings-manager

Inicie el administrador de configuración recién instalado y filtre por "unidad"

Editar "Tecla para abrir el primer menú del panel" para desactivarlo o cambiarlo a otra clave.

Todavía no he encontrado una forma de cambiar F1.

respondido por el Ryan Sorensen 30.04.2011 - 19:36
3

Las instrucciones en enlace (citadas a continuación) también funcionan en Ubuntu 11.04. (Parece que deshabilita F1 tanto en el escritorio como en el terminal. Es decir, F1 no envía una secuencia ansi al shell en el terminal, si eso es lo que OP desea).

  
  1. Vaya a Sistema - Preferencias - Atajos de teclado
  2.   
  3. Crea un nuevo atajo. Nómbrelo 'no hacer nada', y escriba 'falso'   (sin comillas) en el campo "comando". Presiona ok.
  4.   
  5. Desplázate hasta el final de la lista y encuentra tu nuevo comando. Hacer clic   en "Deshabilitado", a la derecha, y presione F1.
  6.   
    
respondido por el David Andersson 22.08.2011 - 04:12
3

Puede desactivarlo fácilmente usando CCSM (Haga clic para instalarlo si no lo tiene instalado) ).

Luego, vaya a Escritorio - & gt; Ubuntu Unity Plugin - & gt; Tecla para abrir el primer menú del panel y deshabilitarlo, o cambiarlo a otro atajo de teclado.

Nota : parece que este método no funciona en Unity2D.

    
respondido por el Binarylife 27.10.2011 - 00:03
2

Este es un consejo para los usuarios de Thnkpad, especialmente T60. Reasigna la clave F1 para escapar. Esto elimina la molesta ventana emergente de la ayuda de la terminal cuando presionas F1. A menudo haces esto debido a la colocación divertida de ESC en T60s.

    
respondido por el ncmathsadist 03.12.2011 - 18:42
1

Si solo quiere cambiar esto en Terminal de Gnome , puede hacer clic en Editar & gt; Atajos de teclado en el Terminal.

    
respondido por el Jeremy Bicha 30.04.2011 - 20:37
1

Recomiendo usar F1 como atajo para otra cosa. Ejecuto Tilda, un terminal de línea de comando estilo terremoto, y el atajo predeterminado es F1. Anula la Ayuda, por lo que nunca tengo la Ayuda iniciando cuando presiono F1. Incluso si no te gusta mucho Tilda, presionar F1 nuevamente para ocultarlo es mucho menos tedioso que cerrar la Ayuda después de ejecutarla accidentalmente.

    
respondido por el titaniumtux 03.12.2011 - 20:23
1

12.04

F1 no parece hacer nada de fábrica el 12.04
F10 aparece para simular un clic con el botón derecho del mouse
Entonces, en respuesta a los detalles de la pregunta, no hay necesidad de deshabilitar la ayuda y las notificaciones.

Todavía puede asignarlos a algo más como esto:
El mapeo de teclas rápidas en 12.04 se realiza simplemente a través del widget Teclado.

En el iniciador de Unity encontrar el teclado.

En la ventana que se abre, selecciona la pestaña de accesos directos y los accesos directos personalizados.
Haga clic en el signo más para agregar un nuevo acceso directo.

Llámalo a lo que coincida con la funcionalidad que le asignas.
Ingrese el comando que desea ejecutar en el comando.

En el lado derecho de la ventana, haz clic donde dice desactivado. Esto debería alternar a New Accelerator.

Ahora solo presione F10 .
El acelerador de accesos directos personalizados que definió anula el comportamiento de simulación con el botón derecho. Podría establecer este comando en echo 'nope' > /dev/null si solo desea que su F10 no haga nada.

    
respondido por el RobotHumans 02.04.2012 - 19:50
1

12.04 Sin unidad: desactiva el comportamiento de F1 y F11

He instalado Ubuntu 12.04 / 64 y he eliminado Totality de él siguiendo estas indicaciones. . Muchas de las herramientas que modifican el comportamiento de Unity, por lo tanto, no funcionan. En particular, CCSM ya no "ve" los atajos de teclado.

Descubrí que el método que usaba Editar- & gt; Atajos de teclado en la ventana del terminal tampoco funcionaba. Después de jugar un poco, descubrí que mirando más abajo en la ventana Teclas de acceso directo del teclado en la sección Teclas de acceso directo , F1 y F11 todavía estaban definidas en sus atajos respectivos.

Para solucionar esto,

  1. Haga clic en "F11" en el campo de la derecha de la línea que define F11 como pantalla completa. El texto cambiará a "Nuevo acelerador ...".

  2. Escribe otra secuencia de teclas menos objetable (como alt-F11) y esa combinación de teclas reemplazará el atajo. Si alguien sabe cómo escribir "nada", avísenos.

  3. Repita para la tecla F1.

respondido por el Wes Miller 20.11.2013 - 17:33
0

Ctrl + F1 tampoco funciona. La solución es la misma que para Shift + F10. ¡No olvides el punto y coma como separador!

Coloque esto en ~ / .config / gtk-3.0 / gtk.css:

@binding-set NoKeyboardNavigation {
     unbind "<shift>F10";
     unbind "<control>F1";
}

* {
     gtk-key-bindings: NoKeyboardNavigation;
}
    
respondido por el egmont 16.03.2014 - 12:46

Lea otras preguntas en las etiquetas